New on BenMap, Struggling to validate the excel files for the self pace exercises

Hello guys, Thank you for making BenMap free available, it is very useful.
I am however currently struggling to validate the excel files for PM2.5 for South africa and China. BenMap is not accepting this files, there are errors, I have been trying to fix this errors with no success so far. Please help.

Hi Ismael–sorry to hear that you’ve had trouble importing the air quality data. Can you tell me what validation error you’re receiving?

Hi Neal_Fann, thank you for your reply. most of the errors are with the columns and rows, meaning its not in the right format. I expected the data in the self paced exercise to be in the right format.

Hi Ismael–I’m going to attempt to replicate the issue you’re experiencing. Can you tell me what version of the program you’re using?

Hi Neal, thank you for your reply.
I think the problem is that the excel files that are given for the self paced exercises are not in the right format.
I am not using any programming, I simply just installed the BenMap on my windows pc, downloaded the provided excel/csv files for the training exercises and they are not working. How can they be fixed, I attempted with no success. Please help.

Ismael,

I’m sorry to hear that you are having issues, so this morning I tested both the South Africa and China datasets that are provided online and was able to load them into BenMAP without any issues.

In the screenshot you sent, it seems as though the formatting was changed when the file was opened. I’m not quite sure why the formatting would change, but when I opened it on my computer, the data remained in columns.Can you try downloading the file again, but this time do not open it ahead of time, and try to load it into BenMAP?

I hope this allows you to move forward. Best, Ali

Ismael, I’ve taken the data you’ve sent to Neal and it was able to load without an issue on my computer and I was able to successfully generate BenMAP results. Again, I really think that the file is being corrupted when it is opened, can you try loading it again? Otherwise, you may have to reformat the .csv in Excel by using the “text to columns” tool. Best, Ali

Hi Ali, I seem to have the same problem as Ismael had a couple of months ago. The test self paced monitor data for South Africa comes up with errors upon validation. I have tried to import data without opening file as suggested but have the same issue. I have also tried to reformat the .csv by using excel “text to columns” but no success. I tried using other data from West Africa and encountered the same error messages. Please help

Nick

Just to confirm that this was sorted. It was a simple regional settings issue and the compatibility of decimals. Thanks