Data format for Air Modeling Data

Dear BenMAP-CE users,

I am trying to create a air modeling data file that BenMAP can read. One variable it needs is the “Values”. As the user manual (page 5-4) mentioned, if it is a list of data (e.g., 365 values), then “the list of comma-separated values must be surrounded by quotation marks, otherwise only the first value in the list will be used”. However, I tried different ways, but it always pops up an error message “Value ‘…’ is not a valid float.”.

For example, I have 4 quarterly averaged PM2.5 values over a grid, the values are “8.5,2.5,10,7.6”, then what’s the data format should I put under the “Values” column? I tried (1) 8.5,2.5,10,7.6 (2) ‘8.5’,‘2.5’,‘10’,‘7.6’ or (3) “8.5”,“2.5”,“10”,“7.6”, however, none of them works… I also checked the example (Table 5-2. Sample Air Modeling Data File) provided by user manual (page 5-5), it seems it doesn’t add any single/double quotation around each values.

I appreciate if anyone can provide any suggestion.

Thanks very much,

Best,
Xiangyu

Hi Xiangyu,

I’m sorry to hear that you were unable to import your PM air quality modeling data. I will need a little more information to diagnose and correct the issue. Can you post:

  1. The version of BenMAP-CE you are using
  2. A screen capture of the first several rows of your input data including the column headers

Thanks,
Neal

Hi Dr. Fann,

Thanks for your reply!

  1. The version of BenMAP-CE is v1.3.

  2. The following screenshot is the example of my input data.


    Thank you,

Best,
Xiangyu

Hello Xiangyu,

Thank you for sharing this information. I’ve researched this issue and discovered that you’re experiencing a known bug in version 1.3. There is an open ticket and the developer is planning to fix this (and a variety of other issues) later this Fall.

However, I think I might be able to help you work around this problem. Can you try changing the column header titled “Annual Metric” to “Statistic” and see whether you continue to receive the floating point error? Can you also confirm that data validation is turned off?

Thanks,
Neal

Hi Dr. Fann,

Thank you for your help. If I change the column header from ‘Annual Metric’ to ‘Statistic’, it will pop up another error message “Statistic is not a valid column” (see the attached figure). And what do you mean “data validation is turned off”? Is there any way that I can turn off the data validation function?


Best,
Xiangyu

Hi Xingyu,

Ok, it looks like you should change the column header back to “Annual Metric.”

To turn off data validation:

  1. Navigate to tools
  2. Select option
  3. Deselect the “Require Data Validation for Data Imports” check box.

-Neal

Hi Dr. Fann,

It seems that if I turned off the “Data Validation”, the BenMAP can still import the modeled air quality data without losing any information and won’t impact the further health impact analysis.

I will test more data sets and let you know if I have other questions.

Thank you!

Best,
Xiangyu

2 Likes

Hi Xiangyu,

As Neal mentioned, this is a known issue that is currently being addressed. You can actually leave “Data Validation” turned on and enter your model data by double-clicking on “Source of Air Quality Data” rather than selecting “Baseline” or “Control” individually.

Best,

Will

1 Like

Hi William,

Got it, Thank you for the tip! :smiley:

Best,
Xiangyu