BenMAP cannot detect the Incidence dataset in health impact functions. What are possible causes of this problem?


#1

tect


(Neal) #2

Hello Angela,

The most common explanation for this issue is that the Endpoint and Endpoint Group name in the incidence dataset does not match the Endpoint and Endpoint Group name in the health impact function dataset. Can you confirm that they are identical?


(Ben Ewald) #3

I have a problem that may be similar.
I have a baseline air surface, a control air surface, data sets for population, incidence, and a health function. I have a full set of green lights for sections 1 and 2, but when I run the CFG and get a CFGR file all the results for the point estimate are zero, as if the incidence for all areas is zero. The incidence input file has positive values for incidence, and the data in endpoint and endpoint group is identical to what is in the health function. (Mortality in both cases) so it is a mystery where it is going wrong.
Any suggestions?
Ben Ewald


(Neal) #4

Hi Ben,

Can you confirm that endpoint and endpoint group specified in the incidence rate file match the endpoint and endpoint group specified in your health impact function?


(Ben Ewald) #5

Yes, I saw the response to Angela above, and made sure they were identical. Mortality in both cases. (Both with a capital M as it might be case sensitive.)
Ben


(Ben Ewald) #6

I am still struggling with this problem. The incidence dataset has incorrect values for endpoint group. I am trying to delete the current dataset. It appears to have been deleted. On the Modify Datasets screen, the box for Incidence/prevalence rates is blank. If I then go to MANAGE, then ADD, there are no files visible, but if I click OUTPUT SAMPLE FILE it outputs the old incorrect file that I am trying to delete.
This file has not been deleted, and there seems to be no way to edit it other than delete and replace it.
Do you have any suggestions?


(Ali) #7

Hi Ben, I’m sorry to hear you’ve been struggling a while with this problem. If everything checks out that Neal suggested, then I think your issue may lie in your column/row index and how your grids are talking with one another. Are you using a setup you created? Are you using your own grids?


(Ben Ewald) #8

Hello Ali
I think there is a bug in my version of BenMap. I am using a setup I created. I have loaded an incidence file for mortality, and everything else required. The analysis runs, but all values are zero. I have deleted and replaced the incidence file, making sure the endpoint and endpoint group are recorded identically between the incidence data and the health impact function.
However, when Im in the section for editing the incidence file, and hit the button "output sample file’ it exports a file that is nothing like what I loaded in. This one has 51 rows, and every value is 0.003529. This is not my data, I dont know where it came from . Is the analysis using this file instead of my actual data?

This zombie file with 51 rows is even there when I started a whole new setup and have not entered any data.
What does the “output sample file” button do? I notice it is not mentioned in the instruction manual.
Ben


(Ali) #9

Ben, Our apologies for the confusion over the sample zombie data! That is just to give users an idea of what the dataset should look like if their data loads correctly, so don’t worry, it isn’t actually used in the analysis. One question, when you say all values are zero, what about the “Baseline” column, is that all zeros, too? How about “Population” and the “Delta”? Are those zero? That will all help hone in on where your problem lies. Thank you. Ali


(Ben Ewald) #10

Hi Ali, thanks for clearing up the zombie data.
I have air quality surfaces that I am happy with, both for baseline and control. These display appropriate values, correctly match the grid, and generate suitable delta values. I have Incidence, population, and health impact functions that all look correct, and BenMap creates a cfgrx file. When I run this in point mode, it correctly displays a map of delta values, but on the data tab it displays a column with every value for the point estimate of zero.
The specification of endpoint and endpoint group is identical between the incidence data set and the health impact function. What else could be going wrong?
Ben


(Ben Ewald) #11

The user Nina had a similar problem, but I do not see a solution.
screenshot%20of%20health%20impact%20results25-7-18


(Ben Ewald) #12

I have solved the problem. There is a mistake in the user manual. On page 4-48 in table 4-9 that sets out the field requirements for a health impact function, it states that the variable ‘‘incidence dataset’’ is not a required variable. In fact it is a required variable, otherwise the function has nothing to work with.


(Neal) #13

Thanks Ben, and sorry for the trouble. I’ll make sure we correct this typographical error.